Обновление PHP на FreeBSD < 9

Старый версии FreeBSD перестают работать с портами как это было раньше и для нормальной установки пакетов приходится очень хорошо помучиться что бы установить pkg и все настроить.

Приведу пример как я обновляю PHP на старых версиях. Устанавливать и обновлять со старых реп можно не только PHP, это только пример, а не утверждение.

Для начала нужно удалить старую версию php

pkg_delete -r -f -x php5*

Далее прописываем реп для pkg_add

setenv PACKAGESITE http://ftp-archive.freebsd.org/mirror/FreeBSD-Archive/ports/amd64/packages-{версияFreeBSD}-release/Latest/

К примеру будет (http://ftp-archive.freebsd.org/mirror/FreeBSD-Archive/ports/amd64/packages-8.4-release/Latest/)

Далее все просто

pkg_add -r php55

Если не помните как называется ваш пакет, посетите страницу репа http://ftp-archive.freebsd.org/mirror/FreeBSD-Archive/ports/amd64/packages-8.4-release/Latest/